Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Turbo Boost doesn't work on Honor 8

Pages: [1]
Author Topic: Turbo Boost doesn't work on Honor 8
A4B6
Member
Posts: 5
Post Turbo Boost doesn
on: November 24, 2017 (GMT)

The application works fine on my Honor 8 except Turbo boost which always shows 0.0 with blinking green dot. If it’s relevant my car is an Audi A4 B6 1.9 PDTDI (AVF) QUATTRO from 2003.

Hope you can help me.

Thanks in advance.

piemmm
Administrator
Posts: 6071
Post Re: Turbo Boost doesn
on: November 24, 2017 (GMT)

Hi!

Can you tell me if the following sensors give a reading when you add them:

MAP (Manifold Absolute Pressure) sensor
MAF (Mass Air Flow)

In some cases, the vehicle profile is important to fill out with the correct engine displacement otherwise you may not get a reading

A4B6
Member
Posts: 5
Post Re: Turbo Boost doesn
on: November 24, 2017 (GMT)

Thanks piemmm for your reply.

I will be able to test after leaving the office.

I have found MAF sensor, but the MAP not. What is its specific name?

Regarding vehicle profile can you please check if the values are fine?

Audi A4 B6 1.9 PDTDI (AVF) QUATTRO AVANT from 2003.

https://drive.google.com/file/d/1l3HjAG_q2GnKXV42bqS5OAHlQRwPGhpC/view?usp=drivesdk

A4B6
Member
Posts: 5
Post Re: Turbo Boost doesn
on: November 26, 2017 (GMT)

I have tested the phone with same adapter in another car (Audi A6 C5 2.5 TDI) and without doing profile changes the turbo boost works… More strange thing is that using Torque with another phone (Motorola X 2013), same adapter and applying the same profile settings the Turbo boost works also with my car.

Summaryzing:

1. Torque does not measure turbo boost with Honor 8 and Audi A4 B6 1.9 PDTDI using ELM327.

2. Torque measures turbo boost with Honor 8 and an Audi A6 C5 2.5 TDI using same adapter and profile settings.

3. Torque measures turbo boost with Motorola X 2013 with my Audi A4 B6 1.9 PDTDI using same adapter and profile settings.

What the hell is going on?

P.S.: I see a new version of Torque has been released. Will check with it today.

piemmm
Administrator
Posts: 6071
Post Re: Turbo Boost doesn
on: November 26, 2017 (GMT)

Hi!

Thanks for coming from the replies section on google play – I only get 350 characters to reply with in there and I frequently can’t cram enough information in to help people as well as I could!

It’s likely that you need to adjust one of the app settings to prefer the other sensor that is reading a value – you haven’t said if it was MAP or MAF that was stuck, but I’m going to guess that the MAP sensor is permanently reading 0….

So, in the Settings, OBD Adapter Settings (Scroll down a bit) there’s a setting called ‘Boost Calculation Method’. This is defaulted to MAP, but you may need to change it to MAF and see if that works (you may need to disconnect and reconnect afterwards to get this start using the other sensor)

Once that’s done it should be working fine for you (as per the other device that is working :-)

The only other thing it could be is that the vehicle profile is incorrectly setup (fuel type, and engine displacement are very important here, eg for displacement in litres (ie: 1.6, not 1600) :-)

That’s about it – you should then hopefully be up and running!

A4B6
Member
Posts: 5
Post Re: Turbo Boost doesn
on: November 28, 2017 (GMT)

Hi piemmm,

Thanks for the advise. Using MAF sensor, turbo boost works. It would be still interesting understand why MAP sensor for turbo boost measurement with same car and profile works with an old Motorola X 2013 and doesn’t with Honor 8.

piemmm
Administrator
Posts: 6071
Post Re: Turbo Boost doesn
on: November 28, 2017 (GMT)

Can you tell me what version the other phone/device is running (where it’s working)?

A4B6
Member
Posts: 5
Post Re: Turbo Boost doesn
on: November 28, 2017 (GMT)

Motorola X 2013 runs non rooted stock android 5.0.1.

Pages: [1]
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.167 seconds.

  Follow me on twitter