Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Consult BT

Pages: [1] 2 3
Author Topic: Consult BT
Elgrand E50
Member
Posts: 23
Post Consult BT
on: June 7, 2016 (GMT)

I was wondering if you were looking at doing any more work past the beta stage with the Consult BT adaptor. I have just purchased the Consult BT and found it won’t connect to Torque Pro properly.
It connects via bluetooth and reads the coolant temp but that is all. Is there any tricks I may have missed. I have selected the adaptor in the settings.
I have installed the NDSI lite app and every thing works fine, but Torque is a much better looking app with more features and was hoping to be able to use it instead.
It is being used on a Nissan Elgrand E50 98 model.
Thanks and sorry in advance if I am not supposed to mention competitors apps.

piemmm
Administrator
Posts: 6085
Post Re: Consult BT
on: June 14, 2016 (GMT)

Hi!

I have had only moments spare recently to post and check various things were working, apologies for this as I have been trying to get time to sort some other parts of the app out as well (and things got a little busy for me recently)

I have done some preliminary work with ConsultBT, though the person I was last working with (via email) is no longer responding, so never got as far as testing the code that was put into the app

In the ‘protocol’ part of the vehicle profile (if you’ve chosen the nissan protocol, beta, etc, etc) then you’ll be talking to the consult adapter properly

In that case, it means the code I put in works! Though I may need to tweak it for some more sensors on your vehicle (though I don’t know what’s available)

Can you send me a debug of it working (tag it as ‘consultBT’ in the box that pops up so I can locate it and I’ll have a look to see whats supported of if there can be improvements made

You can send a debug by enabling debugging in the settings, then restarting the app. Connect, poll a few sensors, then go to the realtime information screen, press menu, send debugging information, and type ‘consultbt’ in the box that pops up.

That’ll send me a debug so I can then see the comms session between the ECU and vehicle (and a load of app debug) and I’ll hopefully be able to get more working for you if your vehicle allows those sensors to be read

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 14, 2016 (GMT)

I’ll try that but it doesn’t connect to the ECU it only shows that it connects to the bluetooth. In the Adaptor Status page it says not connected to ECU. Will this matter?
Also thank you for replying.

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 14, 2016 (GMT)

I have tried what you suggested except for the polling of sensors. It is not connecting to the ECU at all and I assume it needs to be connected to the ECU to do a sensor poll. Do I need to use the nissan init string in the wiki or just the consultbt protocol? I have sent a debug through anyway and am hoping there is some information in there for you to work with.

piemmm
Administrator
Posts: 6085
Post Re: Consult BT
on: June 15, 2016 (GMT)

Hi

Got the debugs, thanks!

I can see a couple of issues – I’ll try to improve on them for mondays update (though I won’t be able to test it fully as I don’t currently have a nissan ECU handy).

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 15, 2016 (GMT)

Is the testing something I can help with?
I also have an OBD11 adaptor and the OBD11 to Nissan 14 pin plug if that is any help in the testing.

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 20, 2016 (GMT)

How did you go with update. Is it worth trying to connect my Consult BT now or are there still some things you need to do? If I can help with the testing in any way let me know.

piemmm
Administrator
Posts: 6085
Post Re: Consult BT
on: June 20, 2016 (GMT)

Hi!

I’ve sorted the various bits out that needed adjusting, and hopefully the update will be out tonight or tomorrow night at the latest (You’ll see it appear on Google Play when it’s released). I have some more testing to do first before I can send it out to make sure some of the other changes are working properly

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 20, 2016 (GMT)

Awesome. Looking forward to being able to connect properly and use the app. The other one I mentioned just doesn’t compare quality wise. I will post feedback as soon as I get the update done.
Thanks.

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 23, 2016 (GMT)

When will the update be ready for download?

piemmm
Administrator
Posts: 6085
Post Re: Consult BT
on: June 23, 2016 (GMT)

Hi!

It’s been posted today (took a little longer than expected) and should be available in the next couple of hours, so hopefully you’ll be able to see if it improves things and let me know! :-)

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 23, 2016 (GMT)

Hi nothing seems to have changed. I have sent through two dubugs for you to look at. Would the nissan init string do anything or is that just for obd2 compliant vehicles.

piemmm
Administrator
Posts: 6085
Post Re: Consult BT
on: June 24, 2016 (GMT)

Hi!

Got the debugs, thanks

The init string isn’t used for the consultbt adapter/protocol so it can be left blank.

The debugs show that there is progress on it – it’s “more correct” though there are a couple of things that need changing so I’ll get on those bits on Monday and sort them out

On the second debug, you should have started getting/seeing a few dials working?

dohmar
Member
Posts: 15
Post Re: Consult BT
on: June 28, 2016 (GMT)

I’ve tested the latest version of Torque with the Consult BT adaptor – it connects a little quicker than before but ultimately drops the ECU connection as soon as the first amount of data begins to be streamed.
Using an R32 Skyline GTR RB26 ecu

-D

R32 GTR Owner aiming to get Torque Pro working reliably via ConsultBT

Hardware: Parrot Asteroid Smart, Track Electronics ConsultBT Bluetooth
Software : Default Parrot Asteroid Smart Android 2.3, Torque Pro 1.8.2

downriver_bob
Member
Posts: 1
Post Re: Consult BT
on: June 28, 2016 (GMT)

Hi,

I’m also looking to get torque working on Nissan ConsultBT as it is a much superior app to others available.

I’m trying to connect to 2000 Nissan Terrano ZD30. Anything I can do to help with testing on the Consult Protocol I’d be glad to help. Currently it connects to the adapter but fails to connect to the ECU

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: June 30, 2016 (GMT)

Hi Ian, I just ran Torque for a little run and I did get a couple of sensors responding, they just weren’t logging the information fast enough and kept dropping out. I had throttle position and speed dropping in and out and a constant coolant temperature reading with very minimal dropouts. The mass airflow rate is showing green as if active but isn’t changing its reading at all. There are a few other parameters that have worked, the trip distance, trip time etc.
I have sent through a debug with Consult BT E50 Elgrand as its title and will do another run shortly to send another debug through.
Sorry for the late reply.
Thanks,
Rob.

mr.sneezy
Member
Posts: 8
Post Re: Consult BT
on: July 2, 2016 (GMT)

What’s the issue with getting the Consult compatibility ?
Is it understanding the electrical signalling specifications, or the list of Consult PID equivalents ?

Ian, I may be able to provide some info, I still have documents that I wrote while working such stuff out in the late 90’s on Nissans from that era.
Martin

Elgrand E50
Member
Posts: 23
Post Re: Consult BT
on: July 13, 2016 (GMT)

Hi Ian,
I am just wondering when the next update will be ready. I am eagerly waiting to get Torque running properly.

dohmar
Member
Posts: 15
Post Re: Consult BT
on: August 1, 2016 (GMT)

I too am eager for an update.

-D

R32 GTR Owner aiming to get Torque Pro working reliably via ConsultBT

Hardware: Parrot Asteroid Smart, Track Electronics ConsultBT Bluetooth
Software : Default Parrot Asteroid Smart Android 2.3, Torque Pro 1.8.2

piemmm
Administrator
Posts: 6085
Post Re: Consult BT
on: August 4, 2016 (GMT)

Morning!

Looking at the debugs this morning, thanks for sending them as it gives me a good insight into what’s going on

It still seems like it is stopping responding after a sensor request, the adapter doesn’t reply, so I’ll concentrate on that for the next update (1.8.99 as 1.8.98 is in beta) and I’ll see if I can sort this out. Hopefully it’s something small (it usually is) though it may take a bit of two/fro before I can understand the issue fully (as I don’t have a consult vehicle here to test with)

Pages: [1] 2 3
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.481 seconds.

  Follow me on twitter