Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » wifi connection refused

Pages: [1]
Author Topic: wifi connection refused
ntence2
Member
Posts: 6
Post wifi connection refused
on: April 26, 2016 (GMT)

Hello everyone. I’m new to all of this and need some help.
I have torque pro installed and using a generic wifi obd adaptor. it was working this morning and for the last few days, but now it gives me the error connection refused in the bar on the top of the screen when trying to connect. the wifi is connected to the tablet and the IP is set to 192.168.0.11 port 3500. I have the software set to the same. its almost like something else is using the wifi connection and not allowing TP to connect.

Hoping someone know how to fix this one. thanks for looking.

piemmm
Administrator
Posts: 6082
Post Re: wifi connection refused
on: April 26, 2016 (GMT)

Hi!

(Haven’t seen any debugs yet – what id you put in the box that pops up(so I can locate)

The port is usually 35,000 (not 3,500 as you’ve mentioned above – going to assume a typo, just have to mention just in case)

Check that you can ping the device from the android device. If you can’t ping it then torque isn’t going to be able to connect to it

There’s a ton of ping apps on the market, basically you want to ‘ping’ the IP address to see if you get a response. That will tell you that your android device can see it ok

If it can’t, then it’s time to check the wifi settings!

Next, you can try to TCP connect to the port (basically ‘telnet 192.168.x.x 35000’)

Also, on the wifi adapters just like bluetooth, they only allow one connection at a time, so make sure no other apps are connected (or it’ll stop torque from being able to connect)

The WiFi connection type should be ‘infastructure’ mode, and not ‘ad-hoc’ (most android devices have issues with ad-hoc adpaters which are built for the iphone only)

ntence2
Member
Posts: 6
Post Re: wifi connection refused
on: April 26, 2016 (GMT)

Thanks for your quick response.
I was able to ping the device no problem, but TP still does not connect.
I tried to setup logging but I didn’t want to change any wifi setting to send any logs out, thats why you haven’t seen any.
It looks like all the setting are correct, 192.168.0.11 is the device ip and TP is set the same, the port is 35000, you were correct it was a typo.

it just keeps telling me that connection was refused.

I’m new to android, is there a chance some other software is holding the connection to wifi? i closed all recent app’s.

the error reads,
error connecting: failed connection to 192.168.0.11 (port 35000): connectfailed ECONNREFUSED (connection refused)

ntence2
Member
Posts: 6
Post Re: wifi connection refused
on: April 26, 2016 (GMT)

I just got it working again.
the only things I did were quit and restart a bunch of times and I changed the ip from 11 to 10, which doesn’t match the wifi setting but works!
strange.

piemmm
Administrator
Posts: 6082
Post Re: wifi connection refused
on: April 26, 2016 (GMT)

Hi!

Got the debug, thanks.

There are a couple of interesting things in it – I’ll look at it tonight (have to go out first) and see what’s going on

The adapter is .10 or the android device is .10 / .11?

Regards

Ian

ntence2
Member
Posts: 6
Post Re: wifi connection refused
on: April 26, 2016 (GMT)

I think the adaptor may be a 1.0

I got it working again but after a while only a few of the gauges are receiving now.
this is driving me nuts.

piemmm
Administrator
Posts: 6082
Post Re: wifi connection refused
on: April 26, 2016 (GMT)

Hi!

Had a chance to look at the debug now…

All the other settings you have appear to be fine in the app.

It seems that the adapter isn’t 100% working properly, *or* there appears to be some interruption in the communications

This is causing the the connection to time out and eventually drop the connection.

Quick question – when the adapter has been plugged in for a while, does it get quite hot?

ntence2
Member
Posts: 6
Post Re: wifi connection refused
on: April 27, 2016 (GMT)

I don’t believe it does.
can you recommend an obd to usb cable that will also charge the tablet? I’m thinking about switching to a direct connection to eliminate all com errors.

bobbyjoe
Member
Posts: 5
Post Re: wifi connection refused
on: April 28, 2016 (GMT)

I was having the same exact problem. Just bought the latest version of Torque Pro and it would not connect on either my Samsung S4 phone or my Galaxy Tablet. However, DashCommand would connect just fine (on both Android and iOS).

Then I changed the last number in the IP address from 11 to 10 as you did, even though my device said that it was 11 and viola! Torque now connects!

But my victory was short lived, because it shuts my truck off. ;o( Any ideas?

2001 F-350 7.3L Diesel

Veepeak Wifi OBD2 scanner (got great reviews on Amazon)

http://www.amazon.com/Veepeak-Scanner-Adapter-Diagnostic-Trouble/dp/B00WPW6BAE/

Samsung S4 & Galaxy Tab (2, I think)

ntence2
Member
Posts: 6
Post Re: wifi connection refused
on: May 3, 2016 (GMT)

You have a strange problem. mines not shutting down the truck.

i did find that its very intermittent, sometimes all the gauges work sometimes only one. restarting everything usually fixes it for that trip.
ill be picking up a newer tablet with bluetooth soon and trying a good bluetooth adaptor, or buying a real tuner/monitor.

bobbyjoe
Member
Posts: 5
Post Re: wifi connection refused
on: May 3, 2016 (GMT)

Yes, I ordered a bluetooth adapter as well since I was unable to resolve this issue. Seems like Torque doesn’t like wifi. The second I press the “Adapter Status” button the truck shuts down immediately. Oh well.

bobbyjoe
Member
Posts: 5
Post Re: wifi connection refused
on: May 13, 2016 (GMT)

Ok, so the bluetooth adapter is doing the exact same thing. The second I click “Adapter Status” TorquePro turns my truck off. Any ideas?

2001 7.3L F-350 (Diesel)

Veepeak Bluetooth OBD II Adapter, model VP11

Thanks

bobbyjoe
Member
Posts: 5
Post Re: wifi connection refused
on: May 13, 2016 (GMT)

Update: I turned on the “F-150 bug workaround” (even though I have a F-350 Diesel) and it no longer shuts off. I tried both the wifi and bluetooth adapter and it now works with both.

Capp777
Member
Posts: 2859
Post Re: wifi connection refused
on: May 13, 2016 (GMT)

Quote from bobbyjoe on May 13, 2016
Update: I turned on the “F-150 bug workaround” (even though I have a F-350 Diesel) and it no longer shuts off. I tried both the wifi and bluetooth adapter and it now works with both.

End Quote.

I don’t believe your 2001 diesel is fully OBDII compliant. As a result certain
unknown commands can cause this…

Mode 09 – which is used in adapter status icon functions
to read the VIN.

Unknown pids – test your custom pids KOEO to see if a valid
response is received.

The setting Auto check for DTCs – make sure you deselect this
so it wont execute. Ian may have fixed this by now but worth
checking.

bobbyjoe
Member
Posts: 5
Post Re: wifi connection refused
on: May 15, 2016 (GMT)

Thanks for the tips; I’ll try that. I’ve heard conflicting information about pre-2004 Ford diesels and OBD II compliance. I do know that it wasn’t “required” on diesels until 2004.

I have the official Ford engine diagnosis manual for my year and it talks about OBD II in a way that seems to assume that it is compliant. But . . . maybe it is only “partially” compliant? I don’t know.

Anyway, thanks again for the tips.

soundofring
Member
Posts: 10
Post Re: wifi connection refused
on: July 19, 2018 (GMT)

In Torque setting, you should use .10 IP for most wifi adapters. You can just use DHCP for the OBD2 WiFi on your phone. There seems to be a bug with 7.3L Powerstroke PCM and the solution is to disable Mode in the App Settings.

Pages: [1]
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.365 seconds.

  Follow me on twitter