Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Trans temp, IAT, and MAP

Pages: 1 2 3 4 5 6 [7] 8 9 10 11 12 13
Author Topic: Trans temp, IAT, and MAP
Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 20, 2014 (GMT)

Thanks for the update GW1.

Looks good so far now lets hope
your hot readings are reasonable.

I too cannot post images since I
dont subscribe to those services.

greenwhite1
Member
Posts: 9
Post Re: Trans temp, IAT, and MAP
on: January 20, 2014 (GMT)

I have an external digital trans temp gauge that I have but is not installed yet. I hope to get it installed this coming weekend. Just another way to verify my temps and get you more acturate data.

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 20, 2014 (GMT)

Thats awesome! You, MJ and Maf have
led the way for your 7.3L buddies. I
appreciate your help and hope they do
too.

Thanks again.

Edit:

MJ:

Check your psn posting of pids…

IATf is showing incorrect span. Should be -0.00314.
Boost is missing ) after B.

Edit2:

TFTf is showing incorrect span. Should be -0.00360.

m j
Member
Posts: 92
Post Re: Trans temp, IAT, and MAP
on: January 20, 2014 (GMT)

that forum doesn’t allow edit. i have corrected it in my excel file so next time i copy paste it will be fixed.

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 20, 2014 (GMT)

Ian, if you are reading this thread, can you look
at the polynomial equations. The parser is throwing
paren errors even though the various bits are wrapped
in parens as you suggested in other threads.

The equations work in Excel so I believe this maybe a
parser issue and was hoping you would spot it in the
equation.

m j
Member
Posts: 92
Post Re: Trans temp, IAT, and MAP
on: January 21, 2014 (GMT)

when do we start bugging Ian for DTC scans that work and self tests that work ? :)
I guess we work him to get some of these added to the Ford extended PID list first?

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 21, 2014 (GMT)

Quote from Capp777 on January 20, 2014
Thats awesome! You, MJ and Maf have
led the way for your 7.3L buddies. I
appreciate your help and hope they do
too.

Thanks again.

Edit:

MJ:

Check your psn posting of pids…

IATf is showing incorrect span. Should be -0.00314.
Boost is missing ) after B.

Edit2:

TFTf is showing incorrect span. Should be -0.00360.

End Quote.

Added TFTf correction for psn.

Maf:

For your boost problem try…

Boost
((((A*256)+B)*0.00109)-15.73)-([221127]*0.1) or
((((A*256)+B)*0.00109)-15.73)-[221127]

Not sure if the *0.1 is needed. If your boost reading
is near ~13.2 then use second equation. If your boost
reading is near ~0.0 continue using the first equation.

This boost equation uses your trucks extended pid for
baro.

m j
Member
Posts: 92
Post Re: Trans temp, IAT, and MAP
on: January 21, 2014 (GMT)

that looks promising….

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 21, 2014 (GMT)

Quote from Capp777 on January 13, 2014
MJ:

TP V
Header: C410F1
Mode/Pid: 221154

EGR TP
Header: C410F1
Mode/Pid: 22096C

More pids that might
be tp related.

Edit:

TP V
Header: C410F1
Mode/Pid: 220917

TP V
Header: C410F1
Mode/Pid: 220918

End Quote.

Two more to try for TP.

greenwhite1
Member
Posts: 9
Post Re: Trans temp, IAT, and MAP
on: January 21, 2014 (GMT)

Quote from Capp777 on January 21, 2014
Quote from Capp777 on January 13, 2014
MJ:

TP V
Header: C410F1
Mode/Pid: 221154

EGR TP
Header: C410F1
Mode/Pid: 22096C

More pids that might
be tp related.

Edit:

TP V
Header: C410F1
Mode/Pid: 220917

TP V
Header: C410F1
Mode/Pid: 220918

End Quote.

Two more to try for TP.

Capp if I want to try these do I just enter the header and pid and try the test? What should I expect to see without an equation?

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 21, 2014 (GMT)

You can just enter A or (A*256)+B.

Test response will display the raw hex data
returned by the ecu if it is successful. The
challenge is getting the correct equation for
the raw hex data returned… if it works.

Again, since the 7.3’s are prone to shutting
down with some diagnostic commands test
with KOEO for safety.

Edit:

Will you also post the test response for
221154? MJ’s gauge read zero but he did
get a response. The raw hex data may
still hold an answer.

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 21, 2014 (GMT)

Another attempt at the polynomials…

TFT F
(-1.94*(10^-12)*((A*256)+B)^3)+(2*(10^-7)*((A*256)+B)^2)+(-0.0096*((A*256)+B))+258

IAT C
(-1.96*(10^-12)*((A*256)+B)^3)+(1.96*(10^-7)*((A*256)+B)^2)+(-0.00774*((A*256)+B))+144

(They too worked in Excel).

Note:

Maf’s latest listing of pids on psn are still showing
discrepancies from my postings…

Boost
TFT V
IATc
IATf

greenwhite1
Member
Posts: 9
Post Re: Trans temp, IAT, and MAP
on: January 23, 2014 (GMT)

Capp I test TP V
221154
C410F1
(A*256)+B

Response was
Equation 0.0
6211540000

I have no idea what that means.

220917 and 220918 neither had no response.

greenwhite1
Member
Posts: 9
Post Re: Trans temp, IAT, and MAP
on: January 23, 2014 (GMT)

Capp are EBP MAP and BARO all measured in PSI? If so shouldnt all three read current atmosphere pressure with key off and be reading close to the same psi?

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 23, 2014 (GMT)

If you are using the equations for
EBP psia, MAP psia and Baro psia
they should agree +/- 0.5 with KOEO.

If you subtract the baro value from
the psia reading it will give you psi.
This is what MJ is doing to get near
zero readings on his EBP.

Thanks for testing the other TP sensors.
I will keep looking…

If you get another chance, will you try
the second attempt at the TFT F
polynomial pid to see if parser will
accept this version. (I removed sets of
parens that wrapped the ^ bits.

Thanks again for your help.

Edit:

Am I confusing accelerator pedal pid
with throttle position pid?

Edit2:

It appears that Torque cannot handle exponents
as written in the polynomial equations.

TFT F
-0.00000000000194*(((A*256)+B)*((A*256)+B)*((A*256)+B))
+(0.0000002*(((A*256)+B)*((A*256)+B)))+(-0.0096*((A*256)+B))+258

IAT C
-0.00000000000196*(((A*256)+B)*((A*256)+B)*((A*256)+B))
+(0.000000196*(((A*256)+B)*((A*256)+B)))+(-0.00774*((A*256)+B))+144

m j
Member
Posts: 92
Post Re: Trans temp, IAT, and MAP
on: January 24, 2014 (GMT)

maybe. we dont have a ‘throttle’ we just have an accelerator pedal that sends a signal to ecm

m j
Member
Posts: 92
Post Re: Trans temp, IAT, and MAP
on: January 24, 2014 (GMT)

IAT C
-0.00000000000196*(((A*256)+B)*((A*256)+B)*((A*256)+B))
+(0.000000196*(((A*256)+B)*((A*256)+B)))+(-0.00774*((A*256)+B))+144

that is a lot of typing :)
it seemed to eat that. I will test that and Acel POS in AM.

thank you

m j
Member
Posts: 92
Post Re: Trans temp, IAT, and MAP
on: January 24, 2014 (GMT)

accelerator position works. with (A*256)+B the range is 6400 to 50000

i have to look for typos in the IATc as it was reading 232°f this morn as i scraped the frost from my windows

Capp777
Member
Posts: 2917
Post Re: Trans temp, IAT, and MAP
on: January 24, 2014 (GMT)

Can you post the raw hex values with the
associated IAT C reading from test response
in pid editor? I would like to verify this equation
is giving the expected results by hand.

Torque would not let me wrap the first line of
the equation in parens without error.

Edit:

Pid removed because I couldn’t verify the
source.

m j
Member
Posts: 92
Post Re: Trans temp, IAT, and MAP
on: January 25, 2014 (GMT)

I fixed typos in IATc formula, will check it again

Pages: 1 2 3 4 5 6 [7] 8 9 10 11 12 13
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.479 seconds.

  Follow me on twitter