Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Help required - GM/Duramax Injector Balance Rate testing

Pages: 1 2 3 [4] 5 6 7
Author Topic: Help required - GM/Duramax Injector Balance Rate testing
socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Quote from Capp777 on September 25, 2013
Quote from socalmike on September 25, 2013
Quote from Capp777 on September 25, 2013

Did you run a scan from the menu?

The fact that you were reading a number
at all tells me that the pid is communicating.
But that doesnt mean the pid or values are the
correct ones. For some pids multiple ecus may
respond with different numbers.

Note that scans can take a long time!

Capp777

No i did not. I think it is reading the wrong pid. in 2006 the ecm changed so that might be the problem. On the forums the 01 to 05 seem to be reading fine. It is the 06 and up that are not reading. some one said they got it to read on a 2011

I guessing that is the year it switched to can… do you know the pids
the 2011 used to read the rates?

Capp777

No i dont but i believe he just used the torque app.

Capp777
Member
Posts: 2917
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Try this equation…

((((A*256)+B)*(10/64))-5120)/10

ivecoc65
Member
Posts: 1
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

ciao

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Quote from Capp777 on September 25, 2013

Try this equation…

((((A*256)+B)*(10/64))-5120)/10

Capp777

Still reads the same thing….. -423.3

Capp777
Member
Posts: 2917
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Was hoping the result would be different
since subtracting a different amount.

Are you reading the value while testing
in pid editor or did you delete display
and re-add after changing equation?

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Quote from Capp777 on September 25, 2013

Was hoping the result would be different
since subtracting a different amount.

Are you reading the value while testing
in pid editor or did you delete display
and re-add after changing equation?

Capp777

i am changing the equation and saving it. shut down app. restart and checking. i do not delete the display. i just keep the same one and change the equation. seems like no matter what equation u put it says the same thing. i have tried the 2 equations u gave me.

Capp777
Member
Posts: 2917
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Try deleting display and re-adding. I think I
read somewhere that the display remembers
the old equation.

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

the last equation i tried i changed the equation restarted the app and added the display. reads the same thing. -423.3

Capp777
Member
Posts: 2917
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

That last equation was used successfully
by other posters for older vehicles…
at this point I would look for header and
pid address changes.

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Thanks for the help bud!

Capp777
Member
Posts: 2917
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Could you post the raw data response
you are receiving while in the pid editor?
(Test button).

I would like to check these equations by
hand.

Thanks.

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

Quote from Capp777 on September 25, 2013

Could you post the raw data response
you are receiving while in the pid editor?
(Test button).

I would like to check these equations by
hand.

Thanks…

Capp777

Sure………. i will get back to you later tonight.

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 25, 2013 (GMT)

It says no data

Capp777
Member
Posts: 2917
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 26, 2013 (GMT)

No data using header Auto, Blank or 7E0?

Wonder where the display is getting its
data now.

I tried.

Again I would try using Torquescan to identify
your valid pids.

Thanks again.

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 26, 2013 (GMT)

Quote from Capp777 on September 26, 2013
No data using header Auto, Blank or 7E0?

Wonder where the display is getting its
data now.

I tried.

Again I would try using Torquescan to identify
your valid pids.

Thanks again…

Capp777

using auto header it says no data…..
Thanks for all your help

Capp777
Member
Posts: 2917
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 28, 2013 (GMT)

Has anyone tried headers like 7E0 or 7DF for CAN
to see if data is returned?

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 28, 2013 (GMT)

I can try it.

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 28, 2013 (GMT)

I am using auto header right now

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 28, 2013 (GMT)

I also got torque scan. It is green and still reads -423.27

socalmike
Member
Posts: 28
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: September 28, 2013 (GMT)

The 7eo header does not work. When I do test with auto header this is what I get.
Result for equation -423.26563
Command 22162f
Response 22162f
No data

Pages: 1 2 3 [4] 5 6 7
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.477 seconds.

  Follow me on twitter