Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Help required - GM/Duramax Injector Balance Rate testing

Pages: [1] 2 3 4 5 6 7
Author Topic: Help required - GM/Duramax Injector Balance Rate testing
piemmm
Administrator
Posts: 6082
Post Help required - GM/Duramax Injector Balance Rate testing
on: August 9, 2012 (GMT)

Hi!

I’m trying to get balance rates added to the list of predefined PIDs for GM vehicles – I’ve found the right PID, but I’m getting the conversion wrong somewhere

Does someone who knows what their balance rates are, and have some time spare to try out a PID and tell me what the figures returned back are (together with your known balance rates for each of your injectors?)

pdavester
Member
Posts: 4
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: August 12, 2012 (GMT)

I can maybe help out… I have a duramax and can try to load your PID to see what it returns. But I’m not sure how I get you the other information you need about what my known balance rates are (as I dont know those, or where to look it up).

piemmm
Administrator
Posts: 6082
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: August 12, 2012 (GMT)

Hi!

Thank you very much for the offer – unfortunately though at the moment I need someone that knows what their current balance rates are as well, as I need to verify the scaling against the values they have :-/

pdavester
Member
Posts: 4
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: August 23, 2012 (GMT)

Were you able to verify the scaling for these PIDs?

Sprokcet
Member
Posts: 2
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: November 15, 2012 (GMT)

Hello, I will be able to use a Gm Tech2 for comparison. Can you post the pid information so that can test the conversions against the actuals the Tech2 isseeing. Thanks Peter

joey1983
Member
Posts: 5
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

will this help?

http://www.dieselplace.com/forum/showpost.php?p=4737005&postcount=18

piemmm
Administrator
Posts: 6082
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

Well it seems to confirm the information I already have, so I’ve just enabled those PIDs in the app now (if you update, then re-add the ford lists you should be able to see the new PIDs) – feedback welcome

terryk
Member
Posts: 3
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

Everything needed for Torque can get obtained from my LLY XGuage doc. The PIDs and formulas are all there. I had to scale up the value to get the decimal point precision I wanted (I just tried to match the Tech 2.)Where the “formula” from GM used decimal values (like data/3.2), I multiplied both up until they were whole numbers.

For those that want to extract the math, the Xguage does the math in this order:

1. Multiple (MTH)
2. Divide (MTH)
3. Offset (add subtract) (MTH) (Subtraction is adding the two’s compliment.)
4. Shift the decimal point (RXF)

Once I got them to work on my Xgauge I tried to accurately copy them to the spreadsheet but as you can read, I made some typos and I tried to correct them.

They appear to work on the LB7 too but for the LBZ+ they will need to be converted to CANSF and there is no guarentee GM didn’t change the PIDs. I focused on my LLY.

joey1983
Member
Posts: 5
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

Ian this maybe a stupid question but why would you update FORD if the vehicles in question are CHEVROLET? Thanks for your time

joey1983
Member
Posts: 5
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

I looked through the ford list and do not see balance rates?

amdriven2liv
Member
Posts: 117
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

Quote from admin on March 10, 2013
Well it seems to confirm the information I already have, so I’ve just enabled those PIDs in the app now (if you update, then re-add the ford lists you should be able to see the new PIDs) – feedback welcome

I deleted my Ford list, then added in the update, which I have version 1.6.36.

I do not see any PIDs for Contribution balances for injectors.

I do see that you added some cylinder head temps. Wont work on my Model Year motor, which is fine. Will be a good tool for the newer model years. Glad you have those in there.

My model year doesn’t have those Pids.

Northwest United States

sledstorm1
Member
Posts: 5
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

I also just deleted the lists. I reloaded the gm list and they are in there I will check it out tomorrow.

sledstorm1
Member
Posts: 5
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 10, 2013 (GMT)

I just tried it out, it does not work for me. I have a Lbz duramax which I have heard that the pids are different than the lb7 and lly duramax’s. I hope some one with a lb7 or an lly can try it out.

terryk
Member
Posts: 3
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 11, 2013 (GMT)

Balance Rate mm3 = (N-32768)/64

How you arrive at that would be different in the SGII and Torque.

jbperkins
Member
Posts: 8
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 11, 2013 (GMT)

I got balance rates working for an LLY in Torque Pro. Once I figured out the PIDs I used the custom PID option. It works and I’ve verified the results. I’ll post the info tonight when I get home.

jbperkins
Member
Posts: 8
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 11, 2013 (GMT)

This is how I got the balance rates working. The PIDs for balance rate 1 through 8 are:

22 16 2F
22 16 30
22 16 31
22 16 32
22 16 33
22 16 34
22 16 35
22 16 36

The formula is ((A*256+B)-32768)/64

Use that info to define 8 custom PIDs.

To get it to work with my ELM327 device I had to set the “Very Advanced – ELM 327 custom configuration string” to atz in the vehicle profile settings.

piemmm
Administrator
Posts: 6082
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 12, 2013 (GMT)

Hi

The balance rates are now out of alpha and included in the PID lists – it’s been a while but eventually had enough information to get this sorted – thanks to all of you that helped work out the PIDs and conversions! Based on the feedback I can then take this out of beta once I’m happy the equation is correct

jbperkins
Member
Posts: 8
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 12, 2013 (GMT)

Our equations give the same answer and I’ve verified mine using a scan tool.

Several folks on the Duramax forum had trouble getting the balance rates to work. The thing I posted earlier about putting atz in the ELM327 custom configuration in the vehicle profile settings worked for several people on the Duramax forum.

terryk
Member
Posts: 3
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 12, 2013 (GMT)

Good job! Glad people are getting some use out of this work.

joey1983
Member
Posts: 5
Post Re: Help required - GM/Duramax Injector Balance Rate testing
on: March 14, 2013 (GMT)

Tried adding custom pid above can not get it to work no matter what I do it reads -423.Tried adding atz also with the manually entered pid and the one in the gm pid’s. I have a 2001 LB7

Pages: [1] 2 3 4 5 6 7
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.465 seconds.

  Follow me on twitter