Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » decimal places - Use display default

Pages: [1]
Author Topic: decimal places - Use display default
rgwynnjones
Member
Posts: 26
Post decimal places - Use display default
on: January 5, 2022 (GMT)

How does “use display default” work?

Use case: I’d like to set this to say 2, then add a bunch of gauges of the same class that all require 2 decimal places, and they then have 2 decimal places.

Where can the display default be found, reviewed and changed?
Could this be set by the Pid definition file for each pid.

Right now I have a minimum of 6 press/clicks on each gauge to fix the number of decimal places. It gets old quickly when you have dozens of gauges to fix.

BTW, I’ve tried searching this forum for “use display default” to see if this has been discussed before, but get tons of results none of which contains this string. Also tried use+display+default – get nothing there.

Is there a place on the forum that shows options for the search feature bc I cant seem to get it to do anything really useful.

piemmm
Administrator
Posts: 6623
Post Re: decimal places - Use display default
on: January 8, 2022 (GMT)

Hi!

There currently is no way to change the ‘display default’ in the app as it is something set within the code based on a number of things to do with the display

If you have examples of displays that have decimals that are not what you think they should be (or less useful) then let me know and I can usually sort things out – I do need examples though and telling what’s up :)

1.10.256(stable) is released now so should allow me to work on the next set of feature updates in the app for beta release starting next week

rgwynnjones
Member
Posts: 26
Post Re: decimal places - Use display default
on: January 8, 2022 (GMT)

https://photos.app.goo.gl/nREz5DPSK4GiMtVK6
Here is an example on one of many dash screens (I often use 15 dashboard screens)

I use Torque to show EV data which can include 100+ cell voltage and temp gauges.
In this screen you see gauges with 2,3,1 and no decimal places.

Suggestions:
Create a menu item that lets user set the default number of decimal places. It then applies to future gauge adds.

When press on a gauge, provide a ‘set decimal places to default[2]’ option or similar

Allow default number of decimal places to be defined in the ext pid file.
e.g. here is an example from my current ext pids file;
“0GEN6 Cell063V”,”Cell63″,”22F805″,”((E*256)+F)/100.0″,”0″,”5″,”V”,”7E3″

could have an extra tag to set suggested decimal places to 2;

“0GEN6 Cell063V”,”Cell63″,”22F805″,”((E*256)+F)/100.0″,”0″,”5″,”V”,”7E3″,”dp=2″
But user should still be able to override

Pages: [1]
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.019 seconds.

  Follow me on twitter