Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Torque lite works--Pro does not

Pages: [1]
Author Topic: Torque lite works--Pro does not
jlow_
Member
Posts: 3
Post Torque lite works--Pro does not
on: October 19, 2020 (GMT)

Hi, I recently downloaded Torque lite to test it out with my 2007 Civic Si. It worked immediately, to my excitement. After testing it out, I downloaded the Pro version. However, after over an hour of troubleshooting, I still have not managed to connect the Pro version to my ECU. It’s baffling because I had no issues on the lite version. I have a cheap OBD2 ELM327 wifi adapter (it’s also worked before on other cars/with different obd2 apps). It’s a very old phone running android 4.1.1.

Things I’ve tried: forgetting and reconnecting to the wifi, restarting the app, reinstalling the app, restarting my phone, changing my IP address to be static–matching the app’s, switching to bluetooth mode then back to wifi, starting my engine, messing around with any setting that could be remotely related to the issue, etc. Nothing has worked. When I enter the Realtime Information mode, I instantly get “Cannot connect, check the settings!” I simply don’t understand how the Lite version worked so easily and the Pro version does not. Any help is appreciated.

jlow_
Member
Posts: 3
Post Re: Torque lite works--Pro does not
on: October 19, 2020 (GMT)

After trawling through numerous old threads on this forum, I have tried several fixes that were recommended to people with similar issues. These include: making sure the correct bluetooth device is set in the vehicle profile (as defined in global obd2 settings), making sure Torque Lite is closed and therefore not interfering with the connection, trying specific protocols instead of automatic. No dice. So those are ruled out too.

piemmm
Administrator
Posts: 6085
Post Re: Torque lite works--Pro does not
on: October 19, 2020 (GMT)

Hi!

The pro version definitely works, but you need to ensure nothing at all is connected to the adapter (and that the previous app has disconnected from the adapter)

This includes laptops that may be in range as well – windows can automatically connect to the adapter (Which will block the app) by itself, so also be aware of that.

Lastly, unplug and reconnect the adapter (this will reset it and make sure nothing is connected to it).

If you have had more than one Obd2 adapter paired to the phone in the past, remove that pairing completley as it’s possible the app is trying to connect to the previous adapter. Reselect the adapter in the apps main settings (not the vehicle profile, just use a default vehicle profile to begin with) and you should get connected.

You can speed up the reconnection process by quitting and restarting Torque (which will cause it to immediately start trying to connect to the selected adapter in the main app settings).

Just to be sure you’re on the correct settings, got to the menu (cog) icon, Settings, OBD adapter settings, and then choose bluetooth device.

You can then check the connection progress by going to the ‘Adapter Status’ screen in the app (drag the icons around the dial on the starting page until you see it)

jlow_
Member
Posts: 3
Post Re: Torque lite works--Pro does not
on: October 19, 2020 (GMT)

Thank you for the reply. You were right–I managed to get it working this morning! I’m still not sure what I did differently, but I reconnected the adapter several times, and restarted the app several times, and it finally worked. Thanks for helping out, I’m looking forward to using the app.

Pages: [1]
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.114 seconds.

  Follow me on twitter