Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » elm 327 usb adapter

Pages: 1 2 3 [4] 5
Author Topic: elm 327 usb adapter
vic1234
Member
Posts: 4
Post Re: elm 327 usb adapter
on: July 20, 2012 (GMT)

Hi i got USB OBD2 DEVICE(OPCOM)for Opel cars
it work great with PC but the app don’t see it in the “Select USB Device”
when i connect the obd to my S2 with ICS
Window popups that say it can be used by torque app
but it doesn’t appear in “Select USB Device” i tried different bauds
info from Windows

here is the info from USB Device Info app

Device Info 
Device Path: /dev/bus/usb/002/002
Device Class: Use class information in the Interface Descriptors (0x0)
Vendor ID:  0403
Vendor Name:  Future Technology Devices International, Ltd
Product ID:  07d2
Product Name:  not in db

Interfaces 
Interface #0 
Class: Vendor Specific (0xff)	
Endpoint: #0
Address        : 129 (10000001)
Number         : 1
Direction      : Inbound (0x80)
Type           : Bulk (0x2)
Poll Interval  : 0
Max Packet Size: 64
Attributes     : 000000010	
Endpoint: #1
Address        : 2 (000000010)
Number         : 2
Direction      : Outbound (0x0)
Type           : Bulk (0x2)
Poll Interval  : 0
Max Packet Size: 64
Attributes     : 000000010
Device Info 
Device Path: /sys/bus/usb/devices/2-1/
Device Class: Use class information in the Interface Descriptors (0x0)
Vendor ID:  0403
Vendor Name (reported):  AUTO-M3 Ltd.
Vendor Name (from DB):  Future Technology Devices International, Ltd
Product ID:  4f50
Product Name (reported):  OP-COM USB V2
Product Name (from DB):  not in db

Additional Info 
USB Version: 2.00
Speed: 12
Protocol: 00
Maximum Power: 90mA
Serial Number: FTUU6PC2
perris
Member
Posts: 39
Post Re: elm 327 usb adapter
on: July 20, 2012 (GMT)

thanks for the info and the program ian

it seems either the odb adapter or the usb adapter/cable is bad since the program does not see any device

I think I see the problem, just did a search and found I probably don’t have the right host cable;

You’ll also need a micro USB ‘Host’ cable (as those cables have an extra pin that is connected differently to enable host mode) – it’s unlikely the cable you currently have will work if it’s the normal ‘phone to computer’ cable.

I was using a normal phone to computer cable, i see I have to find the cable you are talking about

best source for that?

DicDic
Member
Posts: 5
Post Re: elm 327 usb adapter
on: July 22, 2012 (GMT)

I have installed “Usb device info” on my Galaxy S2,
when plug Otg adaptor, App find it,
but when plug Elm327 cable it lamp on but App not find it

I tried with usb storage ad it work and app find it

On win this Elm327 work fine.
this in information on win:

[Version]
Signature=”$Windows NT$”
DriverPackageType=PlugAndPlay
DriverPackageDisplayName=%DESC%
Class=USB
ClassGUID={36fc9e60-c465-11cf-8056-444553540000}
Provider=%FTDI%
CatalogFile=ftdibus.cat
DriverVer=03/18/2011,2.08.14

[SourceDisksNames]
1=%DriversDisk%,,,

[SourceDisksFiles]
ftdibus.sys = 1,i386
ftbusui.dll = 1,i386
ftd2xx.dll = 1,i386
FTLang.Dll = 1,i386

[SourceDisksFiles.amd64]
ftdibus.sys = 1,amd64
ftbusui.dll = 1,amd64
ftd2xx64.dll = 1,amd64
ftd2xx.dll = 1,i386
FTLang.Dll = 1,amd64

[DestinationDirs]
FtdiBus.NT.Copy = 10,system32\drivers
FtdiBus.NT.Copy2 = 10,system32
FtdiBus.NTamd64.Copy = 10,system32\drivers
FtdiBus.NTamd64.Copy2 = 10,system32
FtdiBus.NTamd64.Copy3 = 10,syswow64

[Manufacturer]
%Ftdi%=FtdiHw,NTamd64

[FtdiHw]
%USB\VID_0403&PID_6001.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6001
%USB\VID_0403&PID_6010&MI_00.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6010&MI_00
%USB\VID_0403&PID_6010&MI_01.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6010&MI_01
%USB\VID_0403&PID_6011&MI_00.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6011&MI_00
%USB\VID_0403&PID_6011&MI_01.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6011&MI_01
%USB\VID_0403&PID_6011&MI_02.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6011&MI_02
%USB\VID_0403&PID_6011&MI_03.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6011&MI_03
%USB\VID_0403&PID_6014.DeviceDesc%=FtdiBus.NT,USB\VID_0403&PID_6014

[FtdiHw.NTamd64]
%USB\VID_0403&PID_6001.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6001
%USB\VID_0403&PID_6010&MI_00.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6010&MI_00
%USB\VID_0403&PID_6010&MI_01.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6010&MI_01
%USB\VID_0403&PID_6011&MI_00.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6011&MI_00
%USB\VID_0403&PID_6011&MI_01.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6011&MI_01
%USB\VID_0403&PID_6011&MI_02.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6011&MI_02
%USB\VID_0403&PID_6011&MI_03.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6011&MI_03
%USB\VID_0403&PID_6014.DeviceDesc%=FtdiBus.NTamd64,USB\VID_0403&PID_6014

[ControlFlags]
ExcludeFromSelect=*

[FtdiBus.NT]
CopyFiles=FtdiBus.NT.Copy,FtdiBus.NT.Copy2
AddReg=FtdiBus.NT.AddReg

[FtdiBus.NTamd64]
CopyFiles=FtdiBus.NTamd64.Copy,FtdiBus.NTamd64.Copy2,FtdiBus.NTamd64.Copy3
AddReg=FtdiBus.NT.AddReg

[FtdiBus.NT.Services]
AddService = FTDIBUS, 0x00000002, FtdiBus.NT.AddService

[FtdiBus.NTamd64.Services]
AddService = FTDIBUS, 0x00000002, FtdiBus.NT.AddService

[FtdiBus.NT.AddService]
DisplayName = %SvcDesc%
ServiceType = 1 ; SERVICE_KERNEL_DRIVER
StartType = 3 ; SERVICE_DEMAND_START
ErrorControl = 1 ; SERVICE_ERROR_NORMAL
ServiceBinary = %10%\system32\drivers\ftdibus.sys
LoadOrderGroup = Base
AddReg = FtdiBus.NT.AddService.AddReg

[FtdiBus.NT.AddReg]
HKR,,DevLoader,,*ntkern
HKR,,NTMPDriver,,ftdibus.sys
HKR,,EnumPropPages32,,”ftbusui.dll,FTBUSUIPropPageProvider”

[FtdiBus.NT.AddService.AddReg]
;HKR,Parameters,”LocIds”,1,31,00,00,00,32,00,00,00,00
;HKR,Parameters,”RetryResetCount”,0x10001,50

[FtdiBus.NT.Copy]
ftdibus.sys

[FtdiBus.NT.Copy2]
ftbusui.dll
ftd2xx.dll
FTLang.dll

[FtdiBus.NTamd64.Copy]
ftdibus.sys

[FtdiBus.NTamd64.Copy2]
ftbusui.dll
ftd2xx.dll,ftd2xx64.dll
FTLang.dll

[FtdiBus.NTamd64.Copy3]
ftd2xx.dll

[Strings]
Ftdi=”FTDI”
DESC=”CDM Driver Package – Bus/D2XX Driver”
DriversDisk=”FTDI USB Drivers Disk”
USB\VID_0403&PID_6001.DeviceDesc=”USB Serial Converter”
USB\VID_0403&PID_6010&MI_00.DeviceDesc=”USB Serial Converter A”
USB\VID_0403&PID_6010&MI_01.DeviceDesc=”USB Serial Converter B”
USB\VID_0403&PID_6011&MI_00.DeviceDesc=”USB Serial Converter A”
USB\VID_0403&PID_6011&MI_01.DeviceDesc=”USB Serial Converter B”
USB\VID_0403&PID_6011&MI_02.DeviceDesc=”USB Serial Converter C”
USB\VID_0403&PID_6011&MI_03.DeviceDesc=”USB Serial Converter D”
USB\VID_0403&PID_6014.DeviceDesc=”USB Serial Converter”
SvcDesc=”USB Serial Converter Driver”
ClassName=”USB”

Italy

piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: July 22, 2012 (GMT)

1.6.4 is out with a couple of adjustments to the USB side of things.

You may need to reboot your phone (if Google play has cached the old version of the app) to get Google play to see the updated app

DicDic
Member
Posts: 5
Post Re: elm 327 usb adapter
on: July 23, 2012 (GMT)

I found this document:
http://www.ftdichip.com/Support/Documents/White_Papers/WP_001_Connecting_ Peripherals_to_an_Android_ Platform.pdf

at page five there is a flow chart,
my phone continue don’t see Elm327 Usb cable with last Torque version,
You think that I have some chances to see it work?

Italy

perris
Member
Posts: 39
Post Re: elm 327 usb adapter
on: July 23, 2012 (GMT)

ian, if you posted it I missed it, could you give a host cable brand or link that is suitable/

thanks in advance

vic1234
Member
Posts: 4
Post Re: elm 327 usb adapter
on: July 24, 2012 (GMT)

doesnt work for me still no devices in selct usb device

vic1234
Member
Posts: 4
Post Re: elm 327 usb adapter
on: October 15, 2012 (GMT)

so no new news?

gali
Member
Posts: 2
Post Re: elm 327 usb adapter
on: November 5, 2012 (GMT)

I have similar problem as DICDIC. USB adapter is not recognized by Torque, here the information in USB info:

Device Info
Device Path: /sys/bus/usb/devices/1-1/
Device Class: Use class information in the Interface Descriptors (0x0)
Vendor ID: 0403
Vendor Name (reported): FTDI
Vendor Name (from DB): Future Technology Devices International, Ltd
Product ID: 6001
Product Name (reported): FT232R USB UART
Product Name (from DB): FT232 USB-Serial (UART) IC

Additional Info
USB Version: 2.00
Speed: 12
Protocol: 00
Maximum Power: 90mA
Serial Number: AE01JN0Y

Under Windows this OBD adapter communicates both with car ECU and computer. Is there any chance to get this OBD adapter running under Torque Pro?

gali
Member
Posts: 2
Post Re: elm 327 usb adapter
on: November 9, 2012 (GMT)

Is the FTDI adapter described above supported in Torque Pro?

rektor
Member
Posts: 7
Post Re: elm 327 usb adapter
on: November 17, 2012 (GMT)

after a few months break I tried again to run my ELM327 on my galaxy s2, again without effect. Do you have any idea how to deal with it?

piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: November 17, 2012 (GMT)

Added the new vendor ID for that new adapter to the list of known adapters – that’ll be available in 1.6.24

Any USB OTG host cable should work – the hardware needs to support USB host mode though

I’ve tested an S2 on android 4.0.3 (UK version), and it doesn’t seem to support host mode for any connections other than memory devices – this is likely because the device was designed before android 4.0 was made

rektor
Member
Posts: 7
Post Re: elm 327 usb adapter
on: November 25, 2012 (GMT)

Today I tested the USB OTG in Samsung S2 and S3.
Both phones can communicate memory devices, keyboard and mouse connected via USB.
They detect also ELM327 module, but Torque unfortunately still do not see it :(

alexvanwyk
Member
Posts: 3
Post Re: elm 327 usb adapter
on: December 15, 2012 (GMT)

Hi. new user, just bought the program.

I have a sansui etab 801 and an ELM 327 adaptor.

After struggling with it on the pc and eventually changing the baud rate I got it working fine.

I now bought your program for the tablet and it doesnt work.
I followed the steps earlier in this discussion, and found that there is no window popping up asking anything when I plug the unit into the tablet. I have a very short cable, that came with the tablet, with the small usb on the one side and a standard plug on the other side. I know the unit is properly plugged in because the red light is on.
Am I making a mistake somewhere?

Thanks

alexvanwyk
Member
Posts: 3
Post Re: elm 327 usb adapter
on: December 15, 2012 (GMT)

More news

Reading through your forum, I saw something about usb host controll programs. I downloaded one and did a check.
without the ELM plugged in there is only the modem. with it plugged in I get 6001:0403 FTDI FT232R USB UART.

Whatever that means
Thanks again

bloubul7
Member
Posts: 10
Post Re: elm 327 usb adapter
on: February 3, 2013 (GMT)

Good day,

Can you please add support for the Silicon Labs CP210x USB to UART bridge chipset.

Thanks,

Dewald

thefunkygibbon
Member
Posts: 4
Post Re: elm 327 usb adapter
on: April 14, 2014 (GMT)

I’m having much the same problems as other people in here. I have a ft232rl (apparently genuine not a copy) ELM327.
torque recognizes the cable and asks if i want to run torque with it.
But it doesnt seem to connect to the ECU. message comes up moaning about baud rate. I’ve tried all the baud rates and protocol types but none seem to connect.

Its to connect to a 2005 Ford Mondeo st220 (HSCAN/MSCAN). I have connected the same cable to my laptop and ran the forscan app and that connects ok.

I’ve emailed Ian a couple of times over this past few weeks but no response so I’m assuming he’s really busy or something.

Is there anything else I can try? (using a 4.4 based android rom to connect with on an sony z1 phone, also tested with a nexus 7 running 4.4)

stevebubs
Member
Posts: 9
Post Re: elm 327 usb adapter
on: April 15, 2014 (GMT)

Not much help if you insist on using Torque, but I installed Touchscan on my android device after getting fed up of trying to get Torque to work.

Touchscan worked first time…

thefunkygibbon
Member
Posts: 4
Post Re: elm 327 usb adapter
on: April 29, 2014 (GMT)

nice one. just took the plunge and purchased touchscan and it connected first time!!

Such a shame that torque doesn’t work and there seems to be little support (emailed the dev a few times over the past few months but no reply :()

thanks for the heads up on this.

Eighthnote
Member
Posts: 1
Post Re: elm 327 usb adapter
on: August 17, 2015 (GMT)

Hello, hopefully I can get some inside info here. I have tried two of the ELM 327 with my 2001 BMW Z3. The red power light is on and it has made a connection with my android. (blue tooth)
It will not connect to the ECU even though my car is listed as supported. I can plainly see that in the adapter settings in the Torque app. It is connected but “can the adapter talk to the car?” is a no………I can not try the laptop method simply because laptops stop reading those little mini-CD’s many years ago. Again….only one red light comes on the adapter…..no other lights illuminate. Before I go drop a couple hundred on a scanner is there anything I should do or try to get this to communicate with my car’s ECU?

Thank you………

Pages: 1 2 3 [4] 5
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.277 seconds.

  Follow me on twitter