Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » elm 327 usb adapter

Pages: 1 2 [3] 4 5
Author Topic: elm 327 usb adapter
Turningjohn
Member
Posts: 8
Post Re: elm 327 usb adapter
on: July 2, 2012 (GMT)

Hi Eric and Ian, I have successfully connected and run my ELM 327 on Scantool at a baud rate of 38400 so the ELM seems to be working OK. I have then gone thorough all of the baud rate settings on Torque from 1200 up to 460800 each time unplugging the USB connection after changing the rate. I’m not sure if I turned Torque off each time so that’s my next move.
In the mean time can you suggest anything, bearing in mind that although I don’t have many apps this is the only one that gives me the error message “unfortunately the TTS engine has closed down” I now understand that TTS means Text To Speech but I do get this error twice when ever I open Torque.
Thanks John.

mariussw
Member
Posts: 1
Post Re: elm 327 usb adapter
on: July 2, 2012 (GMT)

Some help would be appreciated.

When connecting mey ELM USB based device, I do not get a message from Android asking which app I want to use with USB. Using FT232R device on USB. Samsung Galaxy S2 with Android ICS 4.0.3. I do get the ‘USB Connector Connected’ indicator on Android.

I have started the vehicle with ELM device plugged into host cable, then plugging host cable into SGS2.

My ELM device is similar as in link below.
http://fotki.yandex.ru/users/dzavalin/view/399971/

Using “USB Device Info” app from marketplace, I get the following for the host cable.

Usb device Reported Under Linux. Nothing Reported under Android.

/sys/bus/usb/devices/usb2
Device Class: USB Hub (0x9)
Vendor ID: 1d6b
Product ID: 0002
Product Name (reported): S3C OTGHCD
USB Version: 2.00
Speed: 480
Serial Number s3cotg

Turningjohn
Member
Posts: 8
Post Re: elm 327 usb adapter
on: July 2, 2012 (GMT)

Further to my earlier post I have now tried using all of the baud rates, unplugging the adapter each time and also closing the Torque App between tries, Still no luck getting any response on any of the dials and Torque does not automatically start as I plug in the adapter.
HHHEEEELLLPPP please.

Turningjohn
Member
Posts: 8
Post Re: elm 327 usb adapter
on: July 3, 2012 (GMT)

A little further information regarding the compatibility of my ELM 327 adapter. It works fine with Scantool.net program on my laptop but cannot be found by Easy ODBII, either the 2.2 or 2.4 versions.
John.

jimnluna
Member
Posts: 3
Post Re: elm 327 usb adapter
on: July 4, 2012 (GMT)

Quote from admin on June 21, 2012
Hi

The free version currently doesn’t support USB, it’s only in the pro version (due to the extra development initially required for this) – I’ll be porting it to the lite version in the next update cycle for the lite version though.

Thanks. I will be buying the pro version.

rektor
Member
Posts: 7
Post Re: elm 327 usb adapter
on: July 5, 2012 (GMT)

I have problem with connection:
Phone: Samsung SGS2 ICS4.0.3 (I9100XXLPW)
Interface: viaken elm327
http://viaken.pl/pl/diagnoza-fiat/interfejs-diagnostyczny-elm-327-can-usb-wersja-v14b.html

it works good with PC.
After connected to SGS2 it shows, that USB device is connected.

USB Device Info
(Android)

Device path: /dev/bus/usb/002/002
Vendor ID: 7073
Product ID: 07d2
Interface #0
Class: Vendor Specyfic (0xff)
  Endpoint: #0
    Address: 129(10000001)
    Number: 1
    Direction: Inbound (0x80)
    Type: Bulk (0x2)
    Poll interval: 0
    Max Packet Size: 64
    Attributes: 000000010
  Endpoint: #1
    Address: 2(00000010)
    Number: 2
    Direction: Outbound (0x0)
    Type: Bulk (0x2)
    Poll interval: 0
    Max Packet Size: 64
    Attributes: 000000010

(Linux)

Device Path: /sys/bus/usb/devices/2-1/
Vendor ID: 7073
Vendor Name (reported): FTDI
Product ID: 3037
Product Name (reported): ELM-327-USB COM-Port

USB Version: 2.00
Speed: 12
Protocol: 00
Maximum Power: 150mA
Serial Number: OBDTOOL

In Torque>Settings>ODB2 Adapter Settings>Select USB device
it shows nothing (“No devices connected”)

Please help

piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: July 5, 2012 (GMT)

Hi

When Torque asked for permission to use the USB device interface, did you hit ‘allow’ or ‘deny’?

If you denied it, then you will need to go into your application manager (in android) and allow the USB permission

Don’t start Torque before you plug the USB device in. When you plug the USB in, torque should try (or ask) to start automatically – if it is not doing this, then check that you allowed Torque to access the USB in your android settings

rektor
Member
Posts: 7
Post Re: elm 327 usb adapter
on: July 5, 2012 (GMT)

Torque hasn’t asked for permission to use the USB device interface.
when Torque should ask for permission?
He hasn’t tried to start automatically when I plug USB.

Settings>Applications>Torque>Permissions:

Your location
Network communication (create Bluetooth connections, full Internet access, GP license check, view Wi-Fi status)
Storage (modify/delete USB storage contents)
Phone calls
System tools (bt administration, make application always run, modify global system settings, prevent phone from sleeping, automatically start at boot)
piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: July 5, 2012 (GMT)

Hm, if it’s not tried to start, then it’s not matching the device/vendor IDs…

I’ve added that adapter type to the list – looks like it just has a different vendor id than the others. In the next update (due this coming friday/saturday) it should then start working for you

Those adapters will need the baud rate setting to 9600 or 19200 though (this is the most common baud rate they use) – if it doesn’t work on those 2, then you’ll have to try each one to see when it starts working

rektor
Member
Posts: 7
Post Re: elm 327 usb adapter
on: July 5, 2012 (GMT)

Ok, i’m waiting for update.
I think 9600 will be ok.

rektor
Member
Posts: 7
Post Re: elm 327 usb adapter
on: July 12, 2012 (GMT)

Still the same problem :/

piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: July 13, 2012 (GMT)

ok – it should be detecting it when you plug in (9600, 19200, and 38400 may be supported baud rates for that adapter)

If you change the baud rate, quit the app and restart it (by plugging the adapter in) if it doesn’t restart when you do that, then I will need to get hold of one of those adapters to see what’s up

rektor
Member
Posts: 7
Post Re: elm 327 usb adapter
on: July 14, 2012 (GMT)

still the same :(
Tomorrow I am going on vacation. Maybe we could talk (skype, gtalk) at the beginning of August. We could once again go through the whole setup, just to make sure that I do not make some stupid mistake.

DicDic
Member
Posts: 5
Post Re: elm 327 usb adapter
on: July 17, 2012 (GMT)

I have tried but haven’t any effect, usb still same problem :(

Italy

piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: July 17, 2012 (GMT)

@dicdic Does torque ask to start when you plug the OBD2 adapter into the device?

DicDic
Member
Posts: 5
Post Re: elm 327 usb adapter
on: July 17, 2012 (GMT)

No, it dont ask anything!

Italy

perris
Member
Posts: 39
Post Re: elm 327 usb adapter
on: July 20, 2012 (GMT)

just upgraded my galaxy s2 to icecream, I have the 327, have tried everything on this thread and there is still no device to connect with

there is no pop up asking for permission, I have tried every baud rate, I have tried ticking the box that says to tick if you’re having trouble talking to obd

is there any method for testing the cable or adapter?

piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: July 20, 2012 (GMT)

Hi

If you aren’t getting the app requesting to start when you plug it in, then it will be due to either:

* The adapter not using a FTDI or Prolific usb to serial chip (The app can only talk to adapters with these chips in)
* The vendor/product USB IDs being different than the ones that the FTDI/Prolific chip usually ship with

If it’s a vendor/product ID mismatch, then you’ll need to find those out so I can add them to the app’s USB mask, then I can drop them in an update (the previous poster did this, but I’m unsure if the IDs were correct)

EDIT: Had another look at the VID that wasn’t working. Turns out that the relevant bit needs decimal and not a hex VID which is why it wasn’t working (it’s not mentioned in the documentation). I’ll get this fixed in 1.6.4 and it should then start detecting it for the other user

perris
Member
Posts: 39
Post Re: elm 327 usb adapter
on: July 20, 2012 (GMT)

Hi Ian, good to be back on the board

It’s the elm 327 everyone’s using so I would be surprised of those issues are the cause

can you tell me how to find the vendor product id thngy you mention?

piemmm
Administrator
Posts: 6623
Post Re: elm 327 usb adapter
on: July 20, 2012 (GMT)

There’s an app called ‘USB Device Info’ that another poster has mentioned above, which seems to give the info needed, and also if you happen to have a linux machine, plugging it into the USB on that, then typing:

lsusb -v

will show lots of information (which can be used to find the correct pid/vid/device/class/subclass information)

Pages: 1 2 [3] 4 5
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.076 seconds.

  Follow me on twitter