Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Assistance Required, custom init command for Holden advanced PIDS

Pages: 1 [2] 3 4
Author Topic: Assistance Required, custom init command for Holden advanced PIDS
cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 14, 2019 (GMT)

You still have not answered the request 1003
you had an error while entering commands ATZATH1 ?
pid 2100 without 22 forward
try in the Terminal

atz
ath1
atsp6
atsh7e2
atcra7ea
20
3e
aa03fe
2cfe0011
aa03fe

or

atz
ath1
atsp6
atsh7e2
atfcsh7e2
atfcsd300040
atfcsm1
atcra7ea
20
3e
aa03fe
2cfe0011
aa03fe

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 14, 2019 (GMT)

1003 came back 7ea0150 – no response. see pic 794 in the previous link, I just uploaded it.

2100 came back 7ea037f2111 (header 7e2 no 22) see pic 806 in the previous link

I’ll correct the terminal command and try the new ones.

Thanks

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 14, 2019 (GMT)

1003 came back 7ea0150
this is the correct and good answer, to see this try 1081
I think the expected answer will be 7EA037F1012

it turns out 1003 there is a command to start a communication session
2100 – 7EA037F2111 – PIDs witch mode 21 not supported

maybe you need to try the option with command 1003
atz
ath1
atsp6
atsh7e2
atcra7ea
20
3e
1003
aa03fe
2cfe0011
aa03fe

or

atz
ath1
atsp6
atsh7e2
atfcsh7e2
atfcsd300040
atfcsm1
atcra7ea
20
3e
1003
aa03fe
2cfe0011
aa03fe

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 14, 2019 (GMT)

The following link has the screenshots from the request from your second last post.

https://drive.google.com/open?id=1O0Jz5v9U_tqMAQF4BgfrmOkPBWtYkuJy

I’ll try the terminal commands from your last post soon.

Thanks again

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 14, 2019 (GMT)

Here is a link to the screen shots from the last suggestions:

https://drive.google.com/open?id=1ZYxsFS1fmKmMfFAKVGjY8fVxuCw5dfM9

it got a few steps further but came back no data after the last command again.

1081 came back with 7ea037f1012 as you said.

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 14, 2019 (GMT)

try this external PID in the mode TEST PID

PID: AA03FE
PIDs
PID
0
100
x1

Equation: A
Header: 7E2
Diagnostic start command: 2CFE0011

and
try creating an external PID and do a PID Test
PID: 221970
Transmission Temp
Trans Temp
0
100
x1

Equation: A
Header: 7E2
Diagnostic start command: 1003

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 15, 2019 (GMT)

Ok will do.

I’ll let you know how it goes.

Cheers

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 15, 2019 (GMT)

https://drive.google.com/folderview?id=15DnsIKCMI_jCC_rdu8rZFSyNn1RnvClU

see results of test pids

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 15, 2019 (GMT)

try this
PID: AA03FD
RPM engine
RPM eng
0
100
x1

Equation: A
Header: 7E2
Diagnostic start command: 2CFD000C

PID: AA03FC
Temp coolant
Temp ccol
0
100
x1

Equation: A-40
Header: 7E2
Diagnostic start command: 2CFC0005

Capp777
Member
Posts: 2862
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 15, 2019 (GMT)

Just curious if an ATCRA is needed?
(5E2 or maybe 5EA) to see the AA…
response?

Edit:

Thanks Cintakc. My phone is so old that
I am not able to see the linked responses.

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 15, 2019 (GMT)

the protocol does not exactly match the protocol Opel
for this block is not necessary atcra5EA, but need atcra7EA
while trying to find the protocol

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 16, 2019 (GMT)

Diagnostic Response for aa03fc – 7EA026CFC (no data for equation)

Diagnostic response for aa03fd – 7EA026CFD (no data for equation)

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 16, 2019 (GMT)

the same PID gave us a positive answer, try it again and another option
PID: AA03FE
PIDs
PID
0
100
x1

Equation: A
Header: 7E2
Diagnostic start command: 2CFE0011

PID: AA03FE
PIDs
PID
0
100
x1

Equation: A
Header: 7E2
Diagnostic start command: 2CFE0005

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 16, 2019 (GMT)

Start Diagnostic response for first pid was: 7EA026CFE, and sometimes 7e8026cfe cam up underneath the above response and went away. Response at bottom was no data, and no response for the equation.

Start Diagnostic response was als 7EA026FE also sometimes 7ea0160 would flash up and go away underneath it and appear in the response at the bottom, which had no data mostly. No response for equation.

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 16, 2019 (GMT)

accepted

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 17, 2019 (GMT)

Sorry I don’t know what those results mean?

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 17, 2019 (GMT)

I don’t know, maybe the answer consists of 2 parts and Torque cannot catch them

danielfbahr
Member
Posts: 48
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 17, 2019 (GMT)

no worries.

Thanks so much for the work you put into it.

Capp777
Member
Posts: 2862
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 17, 2019 (GMT)

Looks like you are getting positive response
to the 2C command creating the dPid but
not seeing a response from AA which requests
data from the created dPid.

I would have expected its response to include
the dPid id as well.

Interesting reading…

https://torque-bhp.com/forums/?wpforumaction=viewtopic&t=3646.0

https://torque-bhp.com/forums/?wpforumaction=viewtopic&t=3053.0

Since Torque will be executing the commands
over and over again, I would use the one shot
form of the AA command. Still wondering if
ATCRA 5EA is needed immediately before the
AA command and removed afterwards using ATCRA
then using the bit shift method with Rx addressing.

Probably best to use a terminal app to test
though.

Edited.

cintakc
Member
Posts: 1460
Post Re: Assistance Required, custom init command for Holden advanced PIDS
on: October 17, 2019 (GMT)

Capp777
you’re right, it’s better to use the terminal in the list mode

we checked(above there are links to answers in the terminal) atcra5ea does not work

here are the real requests from the scanner
2CFE0011
2CFD000C000D199A195419A11957
2CFC19411942194000051980
2CFA199E199F1992199319941995194C
2CF91953199B199719981999194B
AA03FEFDFCFAF9

PID:
2CFE0011
7EA6CFE
AA03FE
7EA0160
we tried like this, the answer is positive 60, but it alternates with a negative answer and maybe 60 is the answer to 20, the ECU closes the communication session itself

perhaps you need to give more time to wait for a response from the ECU upon request AA03FE

Pages: 1 [2] 3 4
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.482 seconds.

  Follow me on twitter