Torque

Forums

Forums

Guest  

Show or hide header
Welcome Guest, posting in this forum require registration.




Torque » Torque OBD ECU Scanner » Torque Discussion / Ideas » Track recorder

Pages: 1 2 3 4 [5] 6 7 8 9 10 11 12 13 14
Author Topic: Track recorder
steeleshark2
Member
Posts: 22
Post Re: Track recorder
on: October 17, 2011 (GMT)

I am still having the issue that it only transfers the speed gauge. It also has a scale on the speed gauge that it is always pegged. I have a Droid X running android 2.3.

piemmm
Administrator
Posts: 6092
Post Re: Track recorder
on: October 17, 2011 (GMT)

That sounds like you may have one of the older style displays (which were removed). It’s a bug, but you should be able to workaround it by deleting all the displays and recreating them in the meantime until I can get an update out

speed2006
Member
Posts: 60
Post Re: Track recorder
on: October 17, 2011 (GMT)

Something is very wrong. During playback, hangs up, can just turn off the phone. The screen does not respond. The video stops, the sound goes on. So far there was no problem with it. Since Update wrong.
Video: 720×480

Samsung Galaxy S7 Edge
Android 6.0.1
ELM327
BMW 325i
Skype: uborka11

piemmm
Administrator
Posts: 6092
Post Re: Track recorder
on: October 17, 2011 (GMT)

Hi

There’s nothing changed in the video playback activity between the versions, what phone/ROM are you using?

speed2006
Member
Posts: 60
Post Re: Track recorder
on: October 17, 2011 (GMT)

Galaxy TAB, Android 2.3.3

Samsung Galaxy S7 Edge
Android 6.0.1
ELM327
BMW 325i
Skype: uborka11

bcblues
Member
Posts: 1
Post Re: Track recorder
on: October 17, 2011 (GMT)

I am having a problem with Track Recorder with my Bionic. It looks fine when recording, but playback shows blocky areas which are purple and green, which change constantly. I think I even saw a HP logo in the colored blocks??? The superimposed displays look fine. I tried high resolution and standard resolution – same issue.

Also, it would be really nice to overlay the “acceleration widget” in Track Recorder.

speed2006
Member
Posts: 60
Post Re: Track recorder
on: October 17, 2011 (GMT)

Quote from admin on October 17, 2011
Hi

There’s nothing changed in the video playback activity between the versions, what phone/ROM are you using?

———————————————–
I do not think the playback is wrong.I think the recording is wrong. For any other player have the same problem. Exception when I use TorqueEncoder. After that the movie will play correctly.
Hmmm.
other issues:
There is a GPSspeed and Speed. The Speed can be renamed to OBD2 Speed?
https://picasaweb.google.com/lh/photo/Jnd6O5gKr42LVRdcquhoXA?feat=directlink

Samsung Galaxy S7 Edge
Android 6.0.1
ELM327
BMW 325i
Skype: uborka11

piemmm
Administrator
Posts: 6092
Post Re: Track recorder
on: October 18, 2011 (GMT)

Hi

I’m redoing the video code again to reorganise it so it hopefully works better on the bionic (unfortunately I don’t have a bionic to test with so will have to rely on feedback from some of the changes I’m doing to try to work around the problem with the cameras driver)

Hopefully will send an update out with that and a few other fixes in the next day or so

bachmark
Member
Posts: 14
Post Re: Track recorder
on: October 18, 2011 (GMT)

Hi
I tried the latest version from track recorder and the new torqueEncoder4.jar on my desire hd.
TorqueEncoder4.jar do not find the videos on the phone, with TorqueEncloder3.jar its ok.
Copy the video to the local HD (C:), TorqueEncoder4.jar detects the videos but stops while encoding with the following messages:
C:\tmp>java -jar TorqueEncoder4.jar
L:(label0) r:(Speed)
L:(label1) r:(Accel(y))
L:(label2) r:(Accel(z))
L:(y0) r:(0.0)
L:(unit1) r:(g)
L:(y1) r:(0.0)
L:(y2) r:(0.0)
L:(unit0) r:(km/h)
L:(unit2) r:(g)
L:(x2) r:(280.0)
L:(min2) r:(-1.0)
L:(x0) r:(0.0)
L:(x1) r:(140.0)
L:(max0) r:(0.0)
L:(max1) r:(1.0)
L:(max2) r:(1.0)
L:(min1) r:(-1.0)
L:(min0) r:(0.0)
L:(class0) r:(org.prowl.recorder.widgets.MeterB)
L:(class1) r:(org.prowl.recorder.widgets.MeterB)
L:(class2) r:(org.prowl.recorder.widgets.MeterB)
L:(pid0) r:(13)
L:(pid2) r:(16716322)
L:(pid1) r:(16716321)
Title:Speed
Title:Accel(y)
Title:Accel(z)
21:18:00.921 [Thread-7] ERROR org.ffmpeg – [mpeg4 @ 0x45e6bd0] timebase not supp
orted by mpeg 4 standard
21:18:00.921 [Thread-7] WARN com.xuggle.xuggler – Error: could not open codec (
../../../../../../../csrc/com/xuggle/xuggler/StreamCoder.cpp:686)
C:\tmp>

The video I tried is recorded with the latest track recorder, it looks like a similar problem as I reported with earlier versions of track recorder , wrong frame rate?.

Thanks

piemmm
Administrator
Posts: 6092
Post Re: Track recorder
on: October 18, 2011 (GMT)

Was this with the latest track recorder that was released this morning(about 4 hours ago)?

bachmark
Member
Posts: 14
Post Re: Track recorder
on: October 18, 2011 (GMT)

Quote from admin on October 18, 2011
Was this with the latest track recorder that was released this morning(about 4 hours ago)?

You are fast, no I tried this before about 10 hours;-)

I will try it again, after work;-)

Thanks

piemmm
Administrator
Posts: 6092
Post Re: Track recorder
on: October 18, 2011 (GMT)

I can’t guarantee it’ll work, but the framerate will definately be set in the media recorder when the video is made. So if it doesn’t work after that update, then it’s a little more effort required to see if I can get xuggler to work (or if the video needs to be further transcoded first :-/)

joelparsons
Member
Posts: 1
Post Re: Track recorder
on: October 18, 2011 (GMT)

Hi Ian,

First of all……awesome job with Torque and plugins, I’ve been really impressed and its obvious you’ve put a lot of hard work in. Nice one!

Enough brown nosing though, I got a problem with the track recorder :-)

I havent always had this problem, it was since a few updates back. Dont remember which though sorry. If you can post the changelog, I might be able to recognise which but I keep getting the following error when trying to start a recording “Unable to start(Possible camera quality setting not supported):start failed”

If i switch too lowest res, attempt to record, i get the same message. If i then switch to high res again, it’ll record but if i stop recording and try again, the error re-appears. I have to switch back and fore resolutions until it works again.

Im using a Sony Ericsson Xperia Arc. I have reinstalled Torque and Trackrecorder too and i was hoping it would fix itself over the last few updates but unfortunately not.

If you could take a look that would be appreciated. If there are any logs/debug info, etc you need then let me know and i’ll send em through.

Many thanks.

bachmark
Member
Posts: 14
Post Re: Track recorder
on: October 18, 2011 (GMT)

Quote from admin on October 18, 2011
I can’t guarantee it’ll work, but the framerate will definately be set in the media recorder when the video is made. So if it doesn’t work after that update, then it’s a little more effort required to see if I can get xuggler to work (or if the video needs to be further transcoded first :-/)

Now I tried the newest track recorder, unfortunately without success, I get the same error as before.
Should I send the video, or can I try to manually start xuggler to find the right settings?

Thanks for your support

speed2006
Member
Posts: 60
Post Re: Track recorder
on: October 18, 2011 (GMT)

Quote from admin on October 18, 2011
I can’t guarantee it’ll work, but the framerate will definately be set in the media recorder when the video is made. So if it doesn’t work after that update, then it’s a little more effort required to see if I can get xuggler to work (or if the video needs to be further transcoded first :-/)

——————————————

The quality is much better, but in HD still stutters. Not so much as before. Much better now. It does not bother me because I use the TorqueEncoder. The repairs to. Maybe that is the fault of phone. I do not know.

Ian
You live in England? Around London?
I’m going to TORQUE DEVELOPMENTS INTERNATIONAL PLC,
Unit 5, Cliffside Trade Park, Motherwell Way,
Thurrock, Essex RM20 3XD. United Kingdom. In England is on the wrong side the steering wheel. :) Or in my country? I need someone who knows the area. Not now. In April.

Samsung Galaxy S7 Edge
Android 6.0.1
ELM327
BMW 325i
Skype: uborka11

billster
Member
Posts: 5
Post Re: Track recorder
on: October 18, 2011 (GMT)

Hi,

I’m having a few probs with TrackRecorder (I have the update from today, the most up to date full Torque, and running an HTC Desire with 2.2)

When I am recording the video, the dials start jumping around and then eventually end up off the screen so I can’t see them, and I can’t get one of them back as it’s jumped right off the top! This is replicated when I view the videos later through the handset.

Also, I can’t seem to export the files .I have the latest Java, I downloaded xuggler, restarted computer, downloaded TorqueEncoder4.jar, opened it, connected phone, entered USB Drive mode – but no files show up in the box to convert.

I have tried doing this on videos that I’ve recorded since the update earlier today too, but no joy.

I enabled debugging mode, but now cannot see how to send debug files.

I’m a bit of an amateur when it comes to computers though…

Bill

Honda Civic Type R EP3 (2005)
HTC Desire (2.2)
ELM 327 OBD2 adaptor (ebay £10 cheapie)

speed2006
Member
Posts: 60
Post Re: Track recorder
on: October 18, 2011 (GMT)

Quote from Ian:
“Copy the ‘torqueRecorder’ folder from the phone to c:\ then restart the app – it should pick the folder (and it’s contents) up”
The best solution. Works for me.

Samsung Galaxy S7 Edge
Android 6.0.1
ELM327
BMW 325i
Skype: uborka11

billster
Member
Posts: 5
Post Re: Track recorder
on: October 18, 2011 (GMT)

Thanks for that! I will try that, once I find where the torquerecorder folder is lol!!

Could you let me know where to find it please??

Also- I saw the vids from your civic- nice car by the way! (I have a Civic type-R as well – 2005 EP3)

I’ve heard good things about TDI in thurrock as well, but don’t live near there myself, although I took my old Escort to Specialised Engines in Grays which is just down the road for some work when I had it…

Honda Civic Type R EP3 (2005)
HTC Desire (2.2)
ELM 327 OBD2 adaptor (ebay £10 cheapie)

speed2006
Member
Posts: 60
Post Re: Track recorder
on: October 18, 2011 (GMT)

You find it on mnt/sdcard/torqueRecorder

Samsung Galaxy S7 Edge
Android 6.0.1
ELM327
BMW 325i
Skype: uborka11

red913
Member
Posts: 21
Post Re: Track recorder
on: October 19, 2011 (GMT)

Problem I’m having is no audio after encoding.

Samsung Fascinate(Galaxy S workaround not needed)
Version 2.2

Torque recorder updated today to newest version.

Everything works great, just no audio.

Pages: 1 2 3 4 [5] 6 7 8 9 10 11 12 13 14
WP-Forum by: Fredrik Fahlstad, Version: 2.4
Page loaded in: 0.463 seconds.

  Follow me on twitter